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1 Basic Components of Spreadsheet

1.1 Worksheet

An Excel Workbook is made up of a set of worksheets. A worksheet is a grid of rows
and columns. Sheets can be added to the workbook by selecting Worksheet from the
Insert menu. The sheet names appear on tabs at the bottom of the workbook window. By
clicking the tabs you can move from sheet to sheet. You can rename a worksheet by
double clicking the tab.

1.2 Cell

The cell is the basic structural unit in a spreadsheet. A cell consists of the intersection of
arow and a column. A cell is identified by a cell name consisting of a vertical numeric
label and a horizontal alphabetic label. For example, the cell where column B and row 5
intersect is cell BS. You use cell references when you write formulas or refer to cells.
The cell name can be preceded by an alphabetic worksheet page label (for example,
Sheetl:Al, Sheetl:B3, Sheet2:CC256, etc), but most of the time you will be working
within a sheet and the worksheet page name is unnecessary.

Generally, you first select the cell or cells you want to work with, and then you enter data
or choose a command. Selected cells appear highlighted on your screen. The active cell
is the cell in which data is entered when you start typing. Only one cell is active at a
time.

1.3  Row

A row is a horizontal series of cells.

1.4 Column

A column is a vertical series of cells.

1.5 Range or Block

A range or block is a specified series of cells. For example:

A1:E1 Row of cells (meaning, literally the row of data from cell A1 to cell E1)
A1:A9 Column of cells (the column of data from Al to A9)

A1:E9 Matrix of cells (the block of data from A1l to E9)
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1.6 Constant Value

Data that are typed directly into a cell; they can be of numeric value or text. Constant
values do not change unless you select the cell and edit the value yourself.

1.7 Formula

A sequence of values, cell references, names, functions, or operators that produces a new
value from existing values. Formulas always begin with an equal sign (=). A value
that is produced as the result of a formula can change when other values in the worksheet
change.

2 Operating Environment

2.1 Arrow Keys

Arrow keys are used to move from cell to cell and to access various menu options in the
main menu bar at the top of the screen.

2.2 Mouse

Any cell (range of cells) or menu option can be accessed directly by picking with the
mouse. You can also scroll the worksheet vertically or horizontally with the mouse, or
switch between worksheets.

2.3 Menu Options

Menu options can be accessed by moving the cursor keys, by holding down the Alt key
and typing the highlighted letter on the menu option, or by selecting an option directly
with the mouse.

2.4 Speedbar

A row of command buttons and drop-down list boxes which provide shortcuts for
choosing commands.

3 Inputting Text

3.1 Default

Text can be characters or any combination of numbers and characters. When you enter
text, the characters align to the left of the cell. If your text begins with a number (like the
“10™ Floor”) enter a space first so that excel knows that you are not trying to enter a
number.

3.2 Alignment

Text can be aligned by selecting one of the alignment buttons on the speed bar or by
selecting the Cells command from the Format menu. Select the Alignment tab, and then
select the alignment desired — left, right, or centered
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3.3 Numbers as Text

If you want to enter a number as text, you must first apply the text format to the blank
cells. Choose the Cells command from the Format menu, select the Number tab, and then
select the Text category and the @ format code. Another way to enter a number as text is
to precede the entry with an apostrophe (') or with a blank space.

3.4 Display Conventions

A single cell can hold up to 255 characters. That means that formulas must be limited in
length to less than 255 characters. Text that exceeds the displayed column width will
display in the adjacent column(s) to the right of the cell if that cell isn’t being used.
Important: If the adjacent columns(s) contain values or other text, then the text will not
fully display: it will only display the portion that fits within the column width! An
alternative is to wrap the text within the column. Choose the Cells command from the
Format menu, select the Alignment tab, and then select the Wrap Text check box.

4 Numbers

4.1 Default

Numbers are right justified in the cell.

4.2 Format

You can easily change the format of a numeric cell by using buttons on the Speedbar to
specify currency, percent, or change the number of decimal places. More detailed
format specifications can be set by selecting the Cells command from the Format menu
and selecting the Number tab.

5 Using Formulas

5.1 Formulas

Cells can be expressed as a function of one or more cells. To create a formula you must
use one or more operators, one or more source cells or numbers, or functions. Formulas
begin with an equal (=) sign.

5.2 Basic Operators

+ Addition =A1+B1

- Subtraction =A1-Bl

* Multiplication =A1*B1

/ Division =A1/Bl1

N Exponents =A1”3 or B1"2 [square roots would be written as A17(1/2)]

() Parenthesis =(A1-B1)*Cl1
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5.3 Order of Evaluation of Operators

If you combine several operators in the same formula, Excel performs the operations in
the following hierarchical order: *, * and /, + and -. If a formula contains operators with
the same priority, Excel evaluates the operators from left to right. If you want to alter the
order of evaluation, use parentheses to group expressions in your formula.

6 Editing

6.1 Typeover

To change the value or label of a cell just begin typing the new entry and hit [enter] or
any one of the cursor keys. Useful for shorter entries.

6.2 Selective Editing

You can selectively edit the contents of a cell in the formula bar by positioning the cursor
with the mouse.

6.3 Selecting Blocks

Select a block either with the mouse or cursor keys. With mouse, select first cell and
drag mouse down and over with left button down to highlight block of cells. With cursor
keys, move the cursor to one of the corners of the block, press the Shift key and continue
to hold it down while moving the cursor to the opposite corner of the block. All cells in
the block will be highlighted except the active cell.

6.4 Copying Blocks

User either the copy and paste commands on the Edit menu or the copy and paste
buttons on the Speedbar (top left buttons next to the scissors). First select cell or block of
cells to copy from. Then select the copy button or menu item. Then select block of cells
to copy to, and select the paste button or menu item.

7 File

7.1 Saving

To save a workbook for the first time or to save a previously saved workbook using a
new name, use the Save As command on the File menu, and type a new name in the File
name text box. It is a good idea to not leave spaces in the file names and to name them
with the fewest letters possible. The file extension xls will automatically be added to the
file name. To save to your disk in Drive a:, you should select the a: drive from the Drives
drop-down list.

To save a file after it's already been saved once, select the Save command on the File
menu.
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7.2 Retrieving

Once you've saved a file to disk, you can retrieve it from the disk to work with it again by
selecting Retrieve on the File menu. You can pick the file you wish to retrieve from the
list box on the Retrieve File dialog box. NOTE: If the drive shown in the Drives list box
isn't the one on which the file you want to retrieve is stored, activate the drop-down list
and select the appropriate drive (generally drive a:).

7.3  Exit

Exit to Windows Environment by selecting Exit on the File menu.

7.4  Printing

Select the Print command from the File menu. The default is to print the used portion of
the currently displayed worksheet. Alternately, you can select a specific cell range to
print. Select the Print button to print.

8 Copying Formulas

Cells or blocks of cells containing formulas can be copied to other cells or blocks of cells.
The results of copying a formula will depend on how cell references are specified within
a formula. There are three types of references: relative references, absolute references,
and mixed references:

8.1 Relative Referencing

When you copy a formula that contains a cell or block reference (for example, Al or
B5:B8), EXCEL assumes that you want the resulting formula to adjust its cell references
relative to its location.

A relative cell address is one that refers to a location containing a value to be used in the
formula. This location has a relationship with the location of the cell containing the
formula. When the formula is copied to a new cell, the cell address changes in relation to
the new cell. For example, assume the contents of cell C3 is the formula =A3+B3. If this
formula is copied to cell C4, the contents of C4 will be the formula =A4+B4. The row
references in the formula changed relative to the change in row from the original formula
cell position. This is how you do rapid row and column operations with just one formula.
You type the formula once, and then you copy it “relatively” to the cells where you want
a similar operation done.

8.2 Absolute Referencing

Sometimes you might not want cell references to adjust when you copy a formula.
Instead, you want the reference to remain absolute.

An absolute cell address is one that refers to a particular cell and its contents. Absolute
references are indicated by a dollar sign prior to the column and row indicator: $D$5 for
example. Let's say that cell A6 contains the formula =$D$5/100. If this formula is then
copied to cell G7, the contents of G7 will be =$D$5/10 (exactly the same as the formula
in A6).
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8.3 Mixed Referencing

Mixed referencing combines a reference of an exact column or row (absolute) with a
relative row or column. For example, the reference $D7 uses an absolute column
reference (column D) with a relative row reference. The reverse is D$7 where row 7 is
absolute. When copying a formula with a mixed cell address, the absolute portion of the
address remains the same, whereas the relative portion changes. Let's say the cell B18
contains the formula =25*$D7. When we copy that formula to C12, it changes to
=25*$D1.

9 Formatting a Worksheet

Select a range of cells (block). To change the block format you use the Format Cells
dialog. This dialog will appear if you do one of the following:

Select Format/Cells from the Main Menu
or

Point at the highlighted block with the cursor and click the right mouse button. This will
bring up a Speed Menu. Select Format Cells at the bottom of the menu.

Tabs on the Format Cells dialog show the block properties that can be modified. Select a
tab with the cursor. The properties that can be modified include the following (note
many of these properties can be modified using buttons on the speedbar):

Number: Change the format of numeric cells (fixed, $, %, etc.)

Alignment: Align labels and numeric entries. Numeric entries can be centered or left-
justified if desired.

Font: Select font type, style and color.
Border: Draw lines around or between cells.
Patterns: Select color for cell background.

Protection: Protect block of cells from user entry.

10 Creating a Chart or Graph

A chart is a graphic representation of worksheet data. Values from worksheet cells, or
data points, are displayed as bars, lines, columns, pie slices, or other shapes in a chart.
Data points are grouped into data series, which are distinguished by different colors or
patterns.

Charts can be embedded in a worksheet when you want to display a chart along with its
associated data, or you can create a chart sheet as a separate sheet in a workbook. The
ChartWizard is a series of dialog boxes that simplifies creating a chart.

10.1 Creating an Embedded Chart on a Worksheet

Select the worksheet data (range or block of cells) you want to graph, and then click the
ChartWizard button. The mouse pointer changes to a cross hair with a chart symbol.
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You can either click anywhere on the worksheet and have the chart placed automatically,
or place the cross hair and drag where you want the chart to appear. Follow the
instructions in the ChartWizard; the chart is added to the worksheet. You can move or
size the chart on the sheet using the mouse.

10.2 Creating a Chart Sheet in a Workbook

To create a chart sheet, select the worksheet data you want to display in the chart, and
choose Chart from the Insert menu , and then choose As New Sheet. Follow the
instructions in the ChartWizard. The new chart sheet is added to the active workbook, to
the left of the worksheet containing the associated data.

10.3 Using ChartWizard to Create an XY (Scatter) Chart

The ChartWizard guides you through the process step by step: you verify your data
selection, select a chart type, and decide whether to add items such as titles and a legend.

STEP 1: Verify the range or block of cells you wish to graph. The block can include
labels that describe the data as well as the values that will be graphed. Note, that the
block of cells does not have to be selected prior to starting ChartWizard. It can be
selected during this step.

STEP 2: Select the chart type. In this case create an XY scatter plot.

STEP 3: Select a format for the XY (scatter) chart. For example, do you want to plot the
points only, points connected by lines, or lines only.

STEP 4: Define whether the data series are in rows or columns, which series defines the
x-axis, and in which row or column legend text is located (for example, column
headings).

STEP 5: Add legends and titles to chart.

When you select finish the chart will be displayed embedded on the worksheet or on a
separate chart sheet.

[Note: an XY chart is most appropriate when we are comparing two numerical variables
that may come in any order. However, as most of the data that we will analyze in
planning is associated with time (years, decades, age groups, etc.) it is easier to use the
Line Chart graph option in most cases. |

10.4 Change Items in a Chart

You can change an item in a chart, by double clicking on the item. For example, you
might want to select the Y-axis and change the scale displayed.
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