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SECTION I:  Instructions for Setting Up AMES V2.XX as a Java 

Project Using the NetBeans IDE (6.0 or higher) 
 

 

Step 1. Download the zip file for AMES from the homepage at 

https://www2.econ.iastate.edu/tesfatsi/AMESMarketHome.htm and extract the 

zipped files to a local directory, say “D:\”.  If, for example, the AMES version is V2.0, 

the extracted files will be held in “D:\ AMESMarket.V2.0”. All screens below are 

depicted for this particular version download. 

 

 
 

Step 2. Open the NetBeans IDE and select File->New Project. 
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Step 3. In the “Categories:” list, select “Java”, and in the “Projects:” list, select 

“Java Project with Existing Sources”. 

 

Step 4. Click “Next  >”. 

 

 
 

Step 5. Click the “Browse” button to find and select the directory holding the 

AMES extracted files, and set the “Project Name:” to the appropriate version 

name (e.g. “AMESMarket.V2.0”). Also, check the “Set as Main Project” box. 

 

 

Step 6. Click “Next >”. 
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Step 7. Click the “Add Folder” button, find and select the AMES source code (src) 

directory (e.g. “D:\ AMESMarket.V2.0\src”), and click “Open”. 

 

 

Step 8. Click “Finish”. 

 

 

 
 

Step 9. Right click the project name (e.g. “AMESMarket.V2.0”), and select the 

“Properties” command. 
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Step 10. From the Project Properties menu, select “Libraries.” 

 

 

 

 
 

Step 11. Click the “Add JAR/Folder” button. 
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Step 12. Find and open the AMES library (“lib”) directory, select all included Jar 

files, and click “open”. Be sure that JDK 1.6 or higher is set as the “Java Platform” 

and that the “Build Projects on Classpath” box is checked.  

 

Step 13.  Click “ok”. 
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Step 14. Again from the “Project Properties” menu, select “Run”, click the “Main 

Class:” browse button, and select “AMESGUIFrame.AMESFrame” as your main 

class.  IMPORTANT:  To ensure U.S. formatting is used for decimal separators and 

other local parameters, some users have reported they found it necessary to 

include one of the following instructions in the “VMOptions” tab:  

      “-Duser.language=en –Duser.region=US” (Win OS)  

      “-Duser.language=en” (Mac OS) 

 

Step 15. Click “Ok”. 

 

 

 
 

Step 16. Select the “Build->Build Main Project (F11)” command from the 

NetBeans menu. 
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Step 17. A “BUILD SUCCESSFUL” message should appear at the bottom of the 

output screen, as shown above. 

 

 
 

Step 18. Select the “Run-> Run Main Project F6” command from the NetBeans 

menu. 

 

 

 
 

Step 19. The above main screen for the AMES Graphical User Interface (GUI) 

should be displayed. 
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SECTION II. Loading and Viewing AMES Test Cases 
 

 

 
 

Step 1. To load the 5-Bus Test Case, select the “Case->Load Test Case-> 

5-Bus Test Case” command from the main AMES GUI menu. 

 
 

 
 

Step 2. To run the 5-Bus Test Case, click the “Start” icon on the AMES GUI toolbar 

or select “Command->Start” from the main AMES GUI menu. 
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Step 3. Scroll down to see the 5-Bus Test Case input displayed in tabular form. 

 

Step 4. To see the output displayed in the form of user-customizable tables or 

charts, from the main AMES GUI menu select either the “View->Output Table View” 

command or the “View->Output Chart View” command. 

 

 

SECTION III: Development of New AMES Test Cases 
 

The best way to understand the different options available in AMES is to load and 

run variations of the 5-Bus and 30-Bus Test Cases provided with the download of 

AMES in the “DATA” directory.  These test cases can be used as templates for the 

creation of new test cases.  How this can be done is discussed below, using the 5-

Bus Test Case for concreteness. 

 

It is suggested that users first load and run the 5-Bus Test Case under its default 

input data settings, as instructed in Section II .  These settings can be viewed and 

studied by selecting the command “Case->Case Parameters” from the main 

AMES GUI menu.   

 

Next, users should try experimenting with modified input data settings for the      5-

Bus Test Case by changing the default settings in the input data screens  accessed 

via “Case->Case Parameters”.   After hitting “Done” in the final input data screen, 

users can run their revised test case by clicking the “Start” icon on the AMES GUI 

toolbar or by selecting “Command->Start” from the main AMES GUI menu. 

 

Users can save their revised input data settings as a new test case in a new file 

with a .dat extension by using the main AMES GUI menu command “Case->Save 

Case As".  For example, these new settings can be saved in a file called 

“NewTest.dat in the AMES “DATA” directory, e.g., d:\Data\NewTest.dat”   (Users 

are not permitted to overwrite the default 5-Bus Test Case input data file in the 

DATA directory – a different file name must be selected).  The new test case can 
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then be loaded by selecting “Case->Open Case->d:\DATA\NewTest.dat” from 

the main AMES GUI menu. 

 

More generally, new test cases can be created from the default 5-Bus Test Case 

in one of three ways, as follows: 

 

(1) Load and run the 5-Bus Test Case, enter input data changes by “Case->Case 

Parameters”,  hit "Done" in the final input data screen (Step 6), and use “Case-> 

Save Case As” to save the new input data as a new test case (with a .dat 

extension) under a new name in the DATA directory (or some other directory). 

 

(2) Within the DATA directory, copy the 5-Bus Test Case into a new .dat file under 

a new name (e.g., d:\DATA\NewTest.dat) and fill in alternative values for 

some/all of the default input data.  Then load this new test case by using the 

AMES GUI menu command “Case->Open Case->d:\DATA\NewTest.dat”.  

 

(3) From the AMES GUI menu, select “Case->New Case” to open a set of input 

data screens that can be filled in with admissible input data values of your own 

choosing.  Click "Done" in the final input data screen and save the data as a 

new test case in a new .dat file in the DATA directory or another directory of your 

choosing. 

 

 

 

SECTION IV: AMES Source Code Modification 
 

AMES is developed entirely in Java.  All source code for AMES is distributed as open 

source; it can be found in the “src” directory of the downloaded AMES Market 

Package.   

 

To modify the AMES source code (as opposed to simply experimenting with 

alternative input data values through AMES GUI settings), you will obviously need 

to know something about Java. 

 

For annotated pointers to online resources that can help you to learn Java, see 

Section II.B (“Introduction to Java”) at the following site: 

 

 

https://www2.econ.iastate.edu/tesfatsi/repastsg.htm 

 

 

 

 

 

https://www2.econ.iastate.edu/tesfatsi/repastsg.htm
https://www2.econ.iastate.edu/tesfatsi/repastsg.htm
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SECTION V. Running AMES Experiments in Batch Mode 

A.  What does “Batch Mode” mean? 

AMES (version V2.0 and higher) supports experiments run in “Batch Mode”.  This 

means that the user can construct a single batch-mode file for automatically 

carrying out successive experiments for one or more user-specified test cases, 

where each experiment for each test case in turn consists of one or more runs 

conducted with one or more user-specified pseudo-random number seed values. 

AMES batch-mode files are designated by a “.bth” extension.  After AMES loads a 

batch-mode file, it executes each indicated run for each indicated test case and 

saves the resulting output data in files. Once the batch-mode file is loaded, this 

entire process is carried out automatically without need for further user actions.  

B.  Illustrative Application 

This subsection illustrates the AMES batch-mode process using the 5-bus and 30-

bus test case data files included with the AMES download in the “DATA” directory. 

The individual test-case data file names are ‘5BusTestCase.dat’ and 

‘30BusTestCase.dat’.    

A sample batch-mode file “30RS_2Cases.bth” for running successive 5-bus and 30-

bus test cases is included in the same directory (“DATA”) as the 5-bus and 30-bus 

test case data files; this is the default directory AMES uses to look for batch-mode 

files.  The contents of this sample batch-mode file are given below: 

// FILENAME 30RS_2Cases.bth 

#RandomSeedsDataStart 

2096966936 

2131965672 

1235967177 

511529502 

1063330821 

870295371 

1815184757 

1880683622 



 

 

12 

122209384 

220366820 

736815417 

132292439 

207226519 

1522886012 

2000909491 

808958575 

1150478587 

173232596 

999975840 

1616038132 

1831032783 

493464018 

930068517 

856336506 

1205573239 

794414294 

1183491260 

1846539650 

437363834 

2013640491 

#RandomSeedsDataEnd 

 

#MultiCasesDataStart 
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5BusTestCase.dat 

30BusTestCase.dat 

#MultiCasesDataEnd 

The explanations for the indicated components of this batch-mode file are as 

follows: 

(1) The line starting with “//” is a comment line. 

(2) The block delimited by “#RandomSeedsDataStart” and 

“#RandomSeedsDataEnd” is for user-specified random seed values to be 

used for the batch-mode experimental runs.  The user is free to select the 

number and value of these random seeds within the admissible data type 

(long 64-bit signed integer) and the admissible range (a minimum value of             

-9,223,372,036,854,775,808, a maximum value of 9,223,372,036,854,775,807).   

In the present example, 30 random seed values happen to be set.     

Note: In contrast, for an individual experimental run, the user specifies a 

single random seed value for this run in the “Simulation Control 

Parameters” screen accessed by the command “Options->Simulation 

Control” in the main AMES GUI. 

(3) The block delimited by “# MultiCasesDataStart” and “# MultiCasesDataEnd” 

is for a user-specified listing of test-case data files. The user can change the 

number of data files as well as the name of the data files. 

The following steps outline how to load this batch-mode file in AMES. 
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Step 1.  To load the batch-mode file 30RS_2Cases.bth, select “Case->Batch 

Mode->Load Batch Mode File” from the main AMES GUI menu. 

 

Step 2.  Select “30RS_2Cases.bth”. 
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Step 3.  Then click the “Open” command or double click “30RS_2Cases.bth”. 

NOTE: At this point, if desired, you can customize the stopping rules to be 

activated for each run of this batch-mode experiment on the “Simulation 

Control Parameters” screen accessed from the main AMES GUI by the 

command “Options-> Simulation Control”.  (Otherwise, the default settings 

for the activation of stopping rules will be applied.)    
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Step 4. You are now ready to load and run the batch-mode file “30RS_2Cases.bth”.   

Click the “Start” icon on the main AMES GUI toolbar or select “Command->Start” 

from the main AMES GUI menu. 

(1) The running information for the batched test-case data files will be displayed 

in the main window. For example, as seen above, the random seed and part 

of the input data information are displayed for the first run for the first test-case 

data file (5BusTestCase.dat). 

(2) AMES first cycles through all runs for the test-case data file listed first in the 

batch-mode file, as determined by the user-specified list of random seeds.  It 

then proceeds to do the same for each successively listed test-case data file. 

(3)  An output data file for each run for each test-case data file is separately 

generated and stored in the same directory (“DATA”) as the test-case data 

files. For example, the output data for the run corresponding to the first random 

seed value and the first test-case data file “5BusTestCase.dat” is stored in an 

output file named “5BusTestCase_0.out”.   

(4)  Note that a zero-based index is used to successively index the user-specified 

random seed values listed in the batch-mode file.  Thus, the “_0” in the output 
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data file “5BusTestCase_0.out” indicates that this is the output data file 

corresponding to the first random seed value listed in the batch-mode file. 

 

Step 5.  To open, load, and view the output data files, for example the output 

data file “5BusTestCase_0.out”, first select “Case->Open Case” from the main 

AMES GUI menu. 
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Step 6.  Select “5BusTestCase.dat”.  Then click the “Open” command or double 

click “5BusTestCase.dat”. 

 

 

Step 7.  Select “Case->Batch Mode->Load Batch Mode Output”. 
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 Step 8.  Select the desired output data file “5BusTestCase_0.out”.   

 

 Step 9.  AMES will check to ensure that your selected output data file (in this 

example “5BusTestCase_0.out”) correctly corresponds to your previously selected 

test-case data file (in this example “5BusTestCase.dat”).  If this check is passed, the 

above type of message will be displayed. 

Step 10.  You can now choose to view the output data in the form of user-

customizable table or chart displays by selecting either the “View->Output Table 

View” command or the “View->Output Chart View” command from the main 

AMES GUI menu. 

 


